WordRider Home
Welcome! Log In Create A New Profile


doesnt work (FRD closes when I start it)

Posted by copahi 
doesnt work (FRD closes when I start it)
November 13, 2014 03:07AM
Dear friends, a few second after I execute the software and when it try to connect, suddenly shut off. I tried to debug it and installed again (without uninstall because I have many links in it) but it looks that there is no solution. Looking inside the folders, there is not any log.
How to repair it?
If it is not possible, how to save the links in it, to uninstall clean and install again?

Thanks in advance

Edited 1 time(s). Last edit at 11/13/2014 06:57AM by ntoskrnl.
Re: doesnt work
November 13, 2014 06:55AM
This is because ZippyShare is playing shenanigans, and I foolishly made our plugin run their scripts with full permissions. The latest version of the plugin fixes this but I understand you can't get far enough to update.

When you start FRD, it tries to download from ZippyShare, and closes. You need to delete the ZippyShare plugin and then update to the latest version. You can find the plugins in the configuration directory %appdata%\VitySoft\FRD\plugins. Delete zippyshare.frp. Now you should be able to start FRD and update plugins.
Re: doesnt work (FRD closes when I start it)
November 13, 2014 10:15AM
Solved. Thank you very much
Re: doesnt work (FRD closes when I start it)
November 14, 2014 01:28AM
For other people having this issue it can be difficult to stop the plugin from starting a download in the 3 seconds you have. I was unable to scroll to the bottom of the list in time to do it. For me I was able to use the shortcut key for salect all then the shortcut key for Pause.
On the MAC Command + A then quickly Command + P. After that the plugin automatically updated itself and all went back to normal.
Re: doesnt work (FRD closes when I start it)
September 20, 2015 07:51PM
I've got this problem on debian 8.0 after some java update.

(only the welcome screen is shown for a few seconds and then it closes silently)

After some unsuccessfull tweaking with strace and similar I found


file in the application directory (for me it was /home/jirka/bin/FreeRapid-0.9u4/startup.properties, but you will probably have it wherever you've installed it) and there is commented --debug switch in it (on line 10).

# Enable debug mode - advanced logging

After uncommenting it and restarting the application (from terminal emulator / command line, so I could see the debug output) it turned out that there was some zombie instance of FRD running on background and the new one I tried to launch failed with

9:11:42 PM INFO: Application is already running. Exiting


So after killing the zombie instance everything worked again.
Re: doesnt work (FRD closes when I start it)
November 21, 2015 03:37AM
Jsem si jistý, že žádný z předchozích hintů nepomohl. Nemožnost regulárně otevřít FRD v žádném debianním klonu existuje od té doby, kdy Oracle koupil firmu Sun a překopal distribuce Javy. Jediná možnost, jak toho času spustit FRD, je tato : Otevřít složku FRD, na složku "frd.jar" klepnout pravou, na roletce zvolit "Otevřít s Oracle Java 6 Runtime". (Na složku "frd.jar" je možno předtím vytvořit odkaz [klepnout na ni pravou, zvolit "Vytvořit odkaz", a ten přenést na Plochu] - ale i přesto je to otvírání FRD trochu pracnější ... .) smoking smiley
Nespoléhejte na Help FRD vydaný autorem, ten je -pokud jde o spuštění FRD v debianních klonech- out of date.
Prosím dejte vědět, zda Vám to funguje.
I am sure, that none of the previous hints did help you.The inability to open FRD in any of the Debian clones exists since the company Oracle bought Sun and dug distribution of Java. The only way to run FRD now is : Open folder FRD, right click to folder "frd.jar", and on the popup menu choose "Open with Oracle java6 Runtime". (For the folder "frd.jar", it is possible to create a link before [right click on it, select the "Create Link" and transfer it to the desktop] - but even though, it's not fast ...).
Do not rely on Help FRD author published, it s -if it comes to running FRD in the Debian clones- out of date.
Excuse my pinguin English, please, & let me know if it works for you.
Re: doesnt work (FRD closes when I start it)
November 21, 2015 06:17AM
Spravne reseni je odstranit OpenJDK ze systemu, nainstalovat Oracle JRE. Nasledne se ujistit ze na prikaz java se pousti oracli Java. Pripadne si k ni zmenit cestu v frd.sh, popr.si nastavit env property JAVA_HOME.


Re: doesnt work (FRD closes when I start it)
November 21, 2015 02:18PM
FRD works fine with OpenJDK 7 and later. OpenJDK 6 is problematic, because it's a bit too different from Oracle Java 6. Java 6 is outdated anyway so you shouldn't be using that.

OpenJDK 7 is quite similar to Oracle Java 7, and OpenJDK 8 is pretty much exactly the same as Oracle Java 8, so FRD works with all of those.
Sorry, only registered users may post in this forum.

Click here to login